Your app currently targets API level 27 and must target at least API level 28

  1. 4 months ago
    Edited 4 months ago by JOHNNY inside

    Google is requesting API28 already. What are you planning to do about it? Please, keep me post. I'm really worried about it. These are the warnings I am receiving while uploading my app:
    -----------------------------------------------------------------------------
    Target API level requirements from August 2019
    Warning:

    Your app currently targets API level 27 and must target at least API level 28 to ensure it is built on the latest APIs optimized for security and performance.

    From August 2019, new apps must target at least Android 9.0 (API level 28).
    From November 2019, app updates must target Android 9.0 (API level 28).

    Tip:

    Change your app's target API level.
    -----------------------------------------------------------------------------

    Unoptimized APK
    Warning:

    This APK results in unused code and resources being sent to users. Your app could be smaller if you used the Android App Bundle. By not optimizing your app for device configurations, your app is larger to download and install on users' devices than it needs to be. Larger apps see lower install success rates and take up storage on users' devices.

    Resolution:

    Use the Android App Bundle to automatically optimize for device configurations, or manage it yourself with multiple APKs.

    An update v3.4 is now available with API Level 28.

  2. admin

    Jul 1 Administrator

    @JOHNNY inside We will be releasing an update with latest API Level 28 before deadline of 1st August.

  3. 3 months ago

    admin

    Jul 30 Administrator Answer

    An update v3.4 is now available with API Level 28.

 

or Sign Up to reply!